Arquivo

Archive for outubro \18\UTC 2012

Simulando Ponto de Troca de Tráfego com Cisco – OPSF e Rotas Estáticas – Modelo Rede MetroBel Belém

18 de outubro de 2012 Deixe um comentário

Boas moçada,

A ideia deste post é falar um pouco sobre como funciona o projeto PTT (Ponto de Troca de Tráfego)  do Nic.br. A ideia do PTT é que entidades locais comuniquem entre si através um pontos de troca de tráfego disponibilizados por PIX instalados pelo Nic.br, sem que para isso consumam seus Links-Ethernet das suas operadoras. Atualmente em Belém, temos apenas duas operadoras de Backbone Nacional: Oi e Embratel. As mesmas não se comunicam no Pará, sendo que para uma entidade A que tenha Link da Oi acessar dados em uma empresa B que tenha Link com a Embratel, terá que dar uma volta em São Paulo/Rio de Janeiro para fazer a comunicação da rede da OI com a Embratel e depois voltar para Belém. Isso aumenta o tempo de resposta do acesso e faz com que dê muitos saltos em vários roteadores, aumentando também a presença de pontos de falhas. Isso acontece mesmo que as empresas estejam no mesmo Bairro.

Caso as Empresas estivessem conectadas à um PIX do Nic.BR, essas empresas se comunicariam localmente através do PTT , diminuindo o tempo de resposta da comunicação, diminuiria também o número de saltos e consequentemente diminuiria a quantidade de pontos de falhas. Outro fator importante nesse aspecto, é que essas empresas não utilizariam seus links de internet para se comunicar, visto que seria um acesso local e gratuito, diminuindo o consumo do Link com a operadora e otimizando o acesso.

Para este primeiro post da série PTT, iremos utilizar rotas estáticas e OSPF (o PTT real utiliza roteamento dinâmico através do protocolo BGP, é requisito ser ASN e ter uma instância BGP rodando) e também utilizaremos uma rede fictícia das principais Universidades presentes na Região Metropolitana de Belém. Essa rede já Existe desde 2005/2006 e um projeto da RNP chamado Rede MetroBel, não é um PTT real, mas utiliza basicamente o mesmo conceito, exceto de quê provê acesso à Internet para algumas instituições e não utiliza BGP.

Neste projeto, vamos utilizar as seguintes Universidades: Unama, UEPA, UFRA, UFPA. Todas elas (para este post) possuem link de internet com a Embratel, mas entre si vão se comunicar via um ponto de troca de tráfego. Ou seja, possuem uma rota default para a operadora, e utilizam rotas estáticas para comunicarem entre si.

Todos os Roteadores envolvidos são o Cisco 2811s, o Roteador da Embratel comunica com outras operadoras de Backbone provendo acesso à internet. O Roteador PIX-UFPA, situado na UFPA, provê acesso entre as universidades não consumindo acesso de LINK-IP. A Embratel fornece para cada instituição um bloco com prefixo /24 (256 ips). Situação descrita na imagem abaixo:

Cenário

Cenário

Os Roteadores tem duas interfaces FastEthernet (0/0 e 0/1) e duas interfaces Ethernet (0/0/0 e 0/1/0).

Vamos usar o seguinte cenário para as Redes nos Roteadores.

Redes

Redes

E os seguintes endereços IPS nos roteadores.

IPS

IPS

Bom, agora que já sabemos qual topologia vamos utilizar, vamos começar a configurar o nosso roteador. Existem regrinhas que eu utilizo nos roteadores antes de começar a configurar:

– Habilitar o protocolo CDP, com ele podemos visualizar quais dispositivos Cisco estão conectados diretamente nos routers e em quais interfaces, além de fornecer também o ip do vizinho. Para habilitar este protocolo, digite no modo configuração ‘cdp run’.

– Desabilitar a opção de converter comandos, não tem coisa mais chata que isso. No modo config digite ‘no ip domain-lookup’.

– Definir o hostname do roteador, para isto no modo config digite ‘hostname nome_do_router’.

Basicamente fica assim:

conf t
hostname UFPA
no ip domain-lookup
cdp run
exit
wr

Agora vamos definir as interfaces a quais iremos atribuir os endereços IPs. Para isso, utilize o comando ‘show cdp neighbors’, ele lhe dirá qual router está conectado em qual interface. Após isso comece a setar os ips nas interfaces junto com o comando ‘no shutdown’ para que ele habilite a interface. Defina também uma descrição para a interface selecionada. Para facilitar, eu coloquei cada a primeira interface FastEthernet  (fa0/0) de cada instituição conectada no router da Embratel, a segunda interface FastEthernet  (fa0/1) conectada no router do PIX da UFPA e a primeira interface Ethernet (Eth 0/0/0) conectada em um switch Cisco 296da rede local.

Vamos configurar cada interface, atribuir uma descrição, definir um hostname, habilitar o protocolo CDP e desabilitar a opção de tradução de comando, não se esqueça do enable.

ROUTER UFPA

conf  t
hostname UFPA
no ip domain-lookup
cdp run                           
inter fa0/0                    
no shutdown                 
ip address 200.241.248.2 255.255.255.252 
description LINK-INTERNET – EMBRATEL              
exit                                                                                             
inter fa0/1                                                                               
no shutdown 
ip address 172.16.0.2 255.255.255.252
description LINK-PTT 
exit 
inter Eth 0/0/0
no shutdown 
ip address 100.100.100.1 255.255.255.0 
description Rede Local
exit 
exit 
wr 

ROUTER UNAMA

conf t
hostname UNAMA
no ip domain-lookup
cdp run
inter fa0/0
no shutdown
ip address 190.10.44.66 255.255.255.252
description LINK-INTERNET – EMBRATEL
exit
inter fa0/1
no shutdown
ip address 172.16.2.2 255.255.255.252
description LINK-PTT
exit
inter Eth 0/0/0
no shutdown
ip address 200.200.200.1 255.255.255.0
description Rede Local
exit
exit
wr

ROUTER UFRA 

conf t
hostname UFRA
no ip domain-lookup
cdp run
inter fa0/0
no shutdown
ip address 201.70.44.2 255.255.255.252
description LINK-INTERNET – EMBRATEL
exit
inter fa0/1
no shutdown
ip address 172.16.4.2 255.255.255.252
description LINK-PTT
exit
inter Eth 0/0/0
no shutdown
ip address 50.50.50.1 255.255.255.0
description Rede Local
exit
exit
wr

ROUTER UEPA

conf t
hostname UEPA
no ip domain-lookup
cdp run
inter fa0/0
no shutdown
ip address 177.30.20.74 255.255.255.252
description LINK-INTERNET – EMBRATEL
exit
inter fa0/1
no shutdown
ip address 172.16.8.2 255.255.255.252
description LINK-PTT
exit
inter Eth 0/0/0
no shutdown
ip address 25.25.25.1 255.255.255.0
description Rede Local
exit
exit
wr

 ROUTER EMBRATEL 

conf t
hostname EMBRATEL
no ip domain-lookup
cdp run
inter fa0/0
no shutdown
ip address 200.241.248.1 255.255.255.252
description LINK-UFPA
exit
inter fa0/1
no shutdown
ip address 190.10.44.65 255.255.255.252
description LINK-UNAMA
exit
inter Eth 0/0/0
no shutdown
ip address 201.70.44.1 255.255.255.252
description LINK-UFRA
exit
inter Eth 0/1/0
no shutdown
ip address 177.30.20.73 255.255.255.252
description LINK-UEPA
exit
exit
wr

ROUTER PIX-UFPA 

conf t
hostname PIX-UFPA
no ip domain-lookup
cdp run
inter fa0/0
no shutdown
ip address 172.16.0.1 255.255.255.252
description LINK-UFPA
exit
inter fa0/1
no shutdown
ip address 172.16.2.1 255.255.255.252
description LINK-UNAMA
exit
inter Eth 0/0/0
no shutdown
ip address 172.16.4.1 255.255.255.252
description LINK-UFRA
exit
inter Eth 0/1/0
no shutdown
ip address 172.16.8.1 255.255.255.252
description LINK-UEPA
exit
router ospf 1
log-adjacency-changes
no redistribute connected subnets
network 172.16.0.0 0.0.0.3 area 1
network 172.16.2.0 0.0.0.3 area 1
network 172.16.4.0 0.0.0.3 area 1
network 172.16.8.0 0.0.0.3 area 1
exit
exit
wr

Pronto, aqui os routers já estão configurados com os devidos ips e os roteadores vizinhos já devem estar comunicando entre si.

Faça os seguintes testes no Router PIX-UFPA, digite os comandos abaixo nele.

 show cdp neighbors

 A saída seria algo assim:

Show cdp neighbors

Show cdp neighbors

Faça testes de ping deste roteador para os roteadores das instituições: 

Ping para o Router da UFPA: ping 172.16.0.2
Ping para o Router da UNAMA: ping 172.16.2.2
Ping para o Router da UFRA: ping 172.16.4.2
Ping para o Router da UEPA: ping 172.16.8.2

PING

PING

Agora vamos definir as rotas default das instituições para a internet. Tudo que seja encaminhado para o roteador da Embratel será encaminhado para frente para poder chegar ao seu destino, ou seja, o Roteador da Embratel possui uma sessão BGP full-routing.

Rota default UFPA (conf t):

ip route 0.0.0.0 0.0.0.0 200.241.248.1

Rota default UNAMA (conf t):

ip route 0.0.0.0 0.0.0.0 190.10.44.65

Rota default UFRA (conf t):

ip route 0.0.0.0 0.0.0.0 201.70.44.1

Rota default UEPA (conf t):

ip route 0.0.0.0 0.0.0.0 177.30.20.73

Agora precisamos definir as rotas que irão compor o roteamento local pelo PTT PIX-UFPA. Para isso vamos utilizar o protocolo de roteamento OSPF.

Para que cada roteador divulgue suas redes, precisamos definir quais interfaces irão participar do OSPF. Essa definição é feita através da rede que está conectada na interface. Primeiro devemos habilitar o processo OSPF e depois divulgar as redes que vão participar do processo.

Para habilitar o OSPF, digite no modo config o comando com um identificador: router ospf 1, em seguida diga ao router para habilitar o log das mudanças com os vizinhos (neighbors) e defina as redes com o comando network. Observação, se uma interface que faça parte do OSPF estiver down , a rede não será divulgada (por este motivo coloquei um switch Cisco 2960 ligado em cada roteador das instituições).

Vamos habilitar o OSPF no Router UFPA e divulgar as redes. Lembrando que as redes que fazem parte do enlace com a Embratel, não devem fazer parte do processo OSPF, pois o roteamento é intra-universidades.

OSPF + Rota Estática

OSPF + Rota Estática

PROCESSO OSPF – ROUTER UFPA

Conf t
router ospf 1
log-adjacency-changes
network 100.100.100.0 0.0.0.255 area 1
network 172.16.0.0 0.0.0.3 area 1
exit
exit
wr

PROCESSO OSPF – ROUTER UNAMA

Conf t
router ospf 1
log-adjacency-changes
network 200.200.200.0 0.0.0.255 area 1
network 172.16.2.0 0.0.0.3 area 1
exit
exit
wr

PROCESSO OSPF – ROUTER UFRA

Conf t
router ospf 1
log-adjacency-changes
network 50.50.50.0 0.0.0.255 area 1
network 172.16.4.0 0.0.0.3 area 1
exit
exit
wr

PROCESSO OSPF – ROUTER UEPA

Conf t
router ospf 1
log-adjacency-changes
network 25.25.25.0 0.0.0.255 area 1
network 172.16.8.0 0.0.0.3 area 1
exit
exit
wr

Pronto, agora devemos habilitar o processo OSPF no Router PIX-UFPA e divulgar as redes conectadas nele. Este router será o responsável pelo roteamento em si do PTT.

PROCESSO OSPF – ROUTER PIX-UFPA

Conf t
router ospf 1
log-adjacency-changes
network 172.16.0.0 0.0.0.3 area 1
network 172.16.2.0 0.0.0.3 area 1
network 172.16.4.0 0.0.0.3 area 1
network 172.16.8.0 0.0.0.3 area 1
exit
exit
wr

Pronto, o cenário está pronto e cada Instituição esta comunicado com as outras instituições via o PIX-UFPA do PTT.

Um bom teste seria um traceroute da UFPA para a UEPA:

Traceroute UFPA - UEPA

Traceroute UFPA – UEPA

Para ver as rotas OSPF e estáticas, utilize o comando abaixo

Show ip route ospf

Show ip route ospf

As vantagens deste modelo são várias:

– Otimizar Link de Internet diminuindo o tráfego do mesmo.
– Agilizar a comunicação intra-universidades.
– Independência das operadoras
– Maior gerência sobre a rede.

Desvantagem deste modelo:

– Maior complexidade na rede.

Tudo que uma instituição desejar acessar e que não esteja no processo OSPF, a instituição irá encaminhar os pacotes para a Embratel.

Lembrando-se de não utilizar o redistribute static e não divulgar redes erradas para não se tornar um router de trânsito, isso faria com que outros routers pudessem acessar a internet através de seu link.

Bom, claro que o OSPF deveria estar com senha, algumas ACL’s deveriam estar ae e outras coisas visando segurança. Bem como este modelo está longe de ser igual a um PTT real que utiliza BGP, AS e filtros de anúncios, mas a ideia é basicamente essa!

Espero que tenham entendido, pois é assim que a internet e os acessos hoje em dia funcionam. Grandes empresas como Google, Facebook, Yahoo, Aol e etc estão se conectando à PTT locais para agilizar a comunicação.

Se alguém quiser o arquivo do Packet Tracer que utilizei, bem como tirar dúvidas ou os arquivos de configuração dos routers deste post, entre em contato através do email beijer00@gmail.com

Até outro post pessoal!

Abraços

Jacques de Beijer

Anúncios

Mudando o editor de texto default do Linux.

16 de outubro de 2012 Deixe um comentário

Boas,

Todos sabem o quanto é horrível editar um arquivo no Linux e na hora o arquivo abre com um ‘nano’, ‘ed’ ou um tal de ‘pico’… Bom, tá certo que eles são um bom quebra galho, mas os mesmos ao meu ver não tem a mesma produtividade que o VIM, mas não deixam de ser simples editores de texto bem intuitivos e fáceis de usar. Por isto, é sempre bom deixar o VIM como padrão.
Na console, basta digitar o comando abaixo e escolher o número da opção desejada.

update-alternatives –config editor

update-alternatives --config editor

Alterando o editor de texto padrão.

Simples assim.

Recomendo fortemente o uso do VIM para editor de textos Linux, ele tem um poder extremo na manipulação de arquivos. Alguns acham ele complexo, mas o mesmo é bem simples e funcional.

Categorias:Linux, Vim Tags:, , , ,

Instalar Portal Liferay no Linux!

12 de outubro de 2012 8 comentários

Esse primeiro post, fala sobre a instalação do Portal LifeRay em ambientes Linux.

O LifeRay é um poderoso gerenciador de conteúdo web, nele pode-se agregar todo um portal multimídia como o G1 e R7.

Portal LifeRay

Para esta instalação, utilizei no meu laboratório de teste o linux Debian Squeeze (6.0 64 bits),  Banco de Dados Mysql (5.1.49), Portal LifeRay (6.1 CE GA2) com Tomcat (Version 7.0.27) e o Java JDK 6u34

Assumo nesta instalação que o Linux já esteja configurado e todos os comandos serão executados como root. Responsablidade por conta de quem digita os comandos aqui citados.

Primeiro passo é preparar o ambiente, no caso a instalação da última versão do MySQL. Como utilizei o Debian, o instalei como default:

# apt-get install mysql-server

Ele vai solicitar a senha (Guarde ela), vamos precisar, você digita a senha e depois confirma a mesma. Aguarde um pouco e o MySQL estará instalado.

Pronto, MySQL instalado.

Segundo passo, é instalar o Java JDK. Baixe  última versão, para esta instalação eu baixei a versão 6u34 .bin. (jdk-6u34-linux-i586.bin Baixe Aqui).  Crie o diretório do java em /usr/java e mova o arquivo do java para dentro deste diretório.

# mkdir /usr/java

Copie o arquivo para dentro do diretório, dê permissão de execução para o arquivo e execute ele.

# cd /usr/java
# cp -ar /root/jdk-6u34-linux-i586.bin /usr/java/
# chmod +x jdk-6u34-linux-i586.bin
# ./jdk-6u34-linux-i586.bin

Pronto, Java JDK instalado.

Terceiro passo é instalar o Portal LifeRay. O Container que eu escolhi foi o Tomcat, mas no site tem outros como Gerônimo, GlassFish e o próprio JBoss. Escolha o que melhor atender sua infraestrutura. No meu caso, Tomcat. Baixe ele aqui, dê preferência sempre para a última versão. No meu caso estou utilizando a 6.1 CE GA2. Após baixar descompacte o arquivo zip e mova para dentro do diretório /usr

unzip liferay-portal-tomcat-6.1.1-ce-ga2-20120731132656558.zip
mv liferay-portal-6.1.1-ce-ga2/ /usr/

Após isto, vamos exportar os paths. Abra o arquivo /etc/profile e insira os caminhos para os paths JAVA_HOME e LIFERAY_HOME. O liferay utiliza estes paths.

# echo ‘export JAVA_HOME=/usr/java/jdk1.6.0_34’ >> /etc/profile
# echo ‘export LIFERAY_HOME=/usr/liferay-portal-6.1.1-ce-ga2/tomcat-7.0.27’ >> /etc/profile
# echo ‘export PATH=$JAVA_HOME/bin:$LIFERAY_HOME/bin:$PATH’ >> /etc/profile

Pronto, as variáveis estão exportadas, vamos atualizá-las e testá las:

# source /etc/profile
# echo $JAVA_HOME
/usr/java/jdk1.6.0_34
# echo $LIFERAY_HOME
/usr/liferay-portal-6.1.1-ce-ga2/tomcat-7.0.27
#

Agora vamos criar a base de dados para  LifeRay no Mysql. Logue no mysql, crie a base e saia.

# mysql -u root -p
DIGITE SUA SENHA DO MYSQL
mysql> CREATE DATABASE lportal DEFAULT CHARACTER SET utf8;
mysql> exit
#

Agora vamos criar o arquivo de configuração do Liferay para conexão com o Mysql.

Entre no diretório
# cd /usr/liferay-portal-6.1.1-ce-ga2/tomcat-7.0.27/webapps/ROOT/WEB-INF/classes/

Crie o arquivo portal-ext.properties e edite ele.

# vi portal-ext.properties

Insira os dados abaixo, depois dê :wq para sair e salvar o arquivo

###### MySQL ######
jdbc.default.driverClassName=com.mysql.jdbc.Driver
jdbc.default.url=jdbc:mysql://localhost/lportal?useUnicode=true&characterEn
coding=UTF-8&useFastDateParsing=false
jdbc.default.username=root
jdbc.default.password=beijer00
schema.run.enabled=true
schema.run.minimal=true

Salve o arquivo e saia dele.

Alguns arquivos dentro do diretório /usr/liferay-portal-6.1.1-ce-ga2/tomcat-7.0.27/bin/ necessitam de permissão para execução. Entre no diretório e dê permissão para os arquivos *.sh

# cd /usr/liferay-portal-6.1.1-ce-ga2/tomcat-7.0.27/bin/
# chmod +x *.sh

Maravilha, agora tudo pronto para a execução do LifeRay. Vamos startar o mesmo com o comando:

# cd /usr/liferay-portal-6.1.1-ce-ga2/tomcat-7.0.27/bin/startup.sh

Para acessar o Portal Liferay, acesso no seu navegador pelo endereço ip do servidor na porta 8080. Como meu ip 10.0.0.104, o acesso seria http//10.0.0.104:8080

Aguarde uns minutos até o LifeRay carregar

Quando ele abir, vai aparecer a imagem abaixo, dê um nome ao seu portal, defina o usuário administrador, escolha sua linguagem e clique em FINISH. Caso você vá usar um outro Banco de Dados como Oracle ou SQL Server, clique na opção Change acima de finish e defina as configurações.

Start Liferay

Aguarde enquanto o LifeRay salva as configurações e se prepara para iniciar o primeiro Login. Assim que concluir ele dará um OK e informará o arquivo onde salvou as configurações. Após isso, clique em “Ir para meu portal”.

Leia o termo e se estiver de acordo, concorde.

O próximo passo seria a configuração de senha do admin, no meu caso Jacques Beijer. Depois configure uma senha de segurança através de pergunta secreta.

life_pass

Após a etapa de definição de segurança, o Portal Liferay vai abrir como a tela abaixo.

Life_Inicial

A tela é bem básica visto que ainda não tem nada criado no Portal. Para isso vá no painel de controle e comece a brincar com o Liferay.

Na tela abaixo é exibida a tela do Painel de Controle do Portal Liferay.

Portal Liferay

Bom, dae em diante é com o Liferay já, este post/tutorial abrange apenas a Instalação do LifeRay no Linux. =]]

No próximo post eu falo sobra a integração do LifeRay com o Active Directory e autenticação SSO, e no terceiro eu falo da integração do mesmo com o software Alfresco.

Podem usar e divulgar esse post à vontade, só peço que o crédito do autor seja mantido.

Abraços à todos

Jacques

Categorias:Liferay, Linux Tags:, , ,